Email Campaigns Not Sending
Incident Report for Bottlenose
Postmortem

We apologize for the problem with the email marketing sending system. We understand it’s import for email campaigns to be delivered at their scheduled times.

The error occurred when an upstream service we use for inlining the CSS used in the email campaign messages changed its URL. This change of URL prevented campaign messages from being rendered. Without rendered messages no campaigns could be sent out.

We have updated the URL of the inline CSS service and normal campaign sending operations have renewed.

Bottlenose 2.9, currently in development, uses a completely different system for rendering its campaign messages. This should prevent this type of issue from occurring in the future.

Posted 9 months ago. Jan 22, 2019 - 13:33 EST

Resolved
We have fixed this issue by updating the URL used for the CSS inline service. We will continue to monitor email campaign sending.
Posted 9 months ago. Jan 22, 2019 - 13:24 EST
Identified
A third party service used to inline the CSS for the email campaign messages has changed its interface. This change is causing the email message rendering component of the email marketing system to fail. We are working on a fix.

Inlining CSS for email messages is necessary to the emails to be rendered correctly across the large variety of email clients in the market.
Posted 9 months ago. Jan 22, 2019 - 07:40 EST
Update
We are continuing to investigate this issue.
Posted 9 months ago. Jan 22, 2019 - 07:38 EST
Investigating
Email Campaign sending is down. A recent upgrade to software on the email sending service has resulted in a problem with campaigns being sent out. Our engineers are working on the issue and hope to have it resolved soon.
Posted 9 months ago. Jan 21, 2019 - 17:10 EST
This incident affected: Email (Email Marketing).