AOL delivery failures
Incident Report for Bottlenose
Resolved
We have received the following update from our email provider:

"AOL made changes to their email system which incorrectly blocked mail. After becoming aware of the issue, AOL made additional changes to resolve this incorrect blocking. All mail is now delivering normally again."
Posted over 2 years ago. Jun 27, 2017 - 13:13 EDT
Identified
We are receiving many delivery failures with AOL.com email addresses. We are working with our upstream email provider towards a resolution.
Posted over 2 years ago. Jun 27, 2017 - 09:20 EDT